From 4e3bec82d2de26cdbcbd5b7a33f824325cb6c569 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 1 Aug 2014 07:10:16 +0000
Subject: [PATCH] cns3xxx: fix building initramfs and non-initramfs together

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

Backport of r41922

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@41923 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/cns3xxx/image/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index ad3789ad..c86b642e 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-	mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage
+	mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
 endef
 
 # Build sysupgrade image
-- 
GitLab