From 991fe920cce1653ca9f110bb02c7fb15ee6e00ad Mon Sep 17 00:00:00 2001
From: jow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sat, 9 Aug 2014 12:11:34 +0000
Subject: [PATCH] BB: build: consider sub-directories when deploying packages
 to image with CONFIG_PER_FEED_REPO (#17430)

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

Backport of r42041

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42089 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package/Makefile b/package/Makefile
index bf1b16fc..0cba8785 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -94,7 +94,7 @@ $(curdir)/install: $(TMP_DIR)/.build
 	- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
 	rm -rf $(TARGET_DIR)
 	[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
-	@$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
+	@$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)$(if $(CONFIG_PER_FEED_REPO),/*)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
 	@for file in $(PACKAGE_INSTALL_FILES); do \
 		[ -s $$file.flags ] || continue; \
 		for flag in `cat $$file.flags`; do \
-- 
GitLab