From c29d34c2e13ea4f126b4903f1d945d353ef96775 Mon Sep 17 00:00:00 2001
From: blogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 3 Aug 2014 11:15:56 +0000
Subject: [PATCH] iputils: add missing includes, fix musl support

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

Backport of r41958

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@41980 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/network/utils/iputils/Makefile        |  6 +++-
 .../iputils/patches/020-include_fixes.patch   | 32 +++++++++++++++++++
 2 files changed, 37 insertions(+), 1 deletion(-)
 create mode 100644 package/network/utils/iputils/patches/020-include_fixes.patch

diff --git a/package/network/utils/iputils/Makefile b/package/network/utils/iputils/Makefile
index eeb6deb9..19061ca7 100644
--- a/package/network/utils/iputils/Makefile
+++ b/package/network/utils/iputils/Makefile
@@ -121,10 +121,14 @@ define Package/iputils-traceroute6/description
   Traces path to a network host (IPv6).
 endef
 
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -D__UCLIBC__
+endif
+
 MAKE_FLAGS += \
 	CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)" \
 	CONFIG_IPV6="$(CONFIG_IPV6)" \
-	CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)" \
+	CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)$(CONFIG_USE_MUSL)" \
 
 define Package/iputils-arping/install
 	$(INSTALL_DIR) $(1)/usr/bin
diff --git a/package/network/utils/iputils/patches/020-include_fixes.patch b/package/network/utils/iputils/patches/020-include_fixes.patch
new file mode 100644
index 00000000..0c977498
--- /dev/null
+++ b/package/network/utils/iputils/patches/020-include_fixes.patch
@@ -0,0 +1,32 @@
+--- a/ping_common.h
++++ b/ping_common.h
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <time.h>
++#include <sys/types.h>
+ #include <sys/param.h>
+ #include <sys/socket.h>
+ #include <linux/sockios.h>
+@@ -24,6 +25,10 @@
+ 
+ #include "SNAPSHOT.h"
+ 
++#ifndef HZ
++#define HZ 100
++#endif
++
+ #define	DEFDATALEN	(64 - 8)	/* default data length */
+ 
+ #define	MAXWAIT		10		/* max seconds to wait for response */
+--- a/clockdiff.c
++++ b/clockdiff.c
+@@ -13,8 +13,6 @@
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netinet/ip_icmp.h>
+-#define TSPTYPES
+-#include <protocols/timed.h>
+ #include <fcntl.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
-- 
GitLab