diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
index 8ad2e71eae3d92ddf16cbcda86acd6cd9a6d8eac..4e49332b6fab43f96691777f7021b4039b718b98 100644
--- a/target/linux/adm8668/Makefile
+++ b/target/linux/adm8668/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=adm8668
 BOARDNAME:=Infineon WildPass ADM8668
-FEATURES:=squashfs
+FEATURES:=squashfs usb pci
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
diff --git a/target/linux/adm8668/config-3.3 b/target/linux/adm8668/config-3.3
index b365db19adced6a4059a058a527e3c4ae6032068..169245d1cc09d0a8b58facae0f097d99e10c465e 100644
--- a/target/linux/adm8668/config-3.3
+++ b/target/linux/adm8668/config-3.3
@@ -94,5 +94,9 @@ CONFIG_TULIP_NAPI=y
 # CONFIG_TULIP_PCI is not set
 CONFIG_TULIP_PLATFORM=y
 # CONFIG_ULI526X is not set
+CONFIG_USB_ARCH_HAS_XHCI=y
+# CONFIG_USB_HCD_BCMA is not set
+# CONFIG_USB_HCD_SSB is not set
+CONFIG_USB_SUPPORT=y
 # CONFIG_WINBOND_840 is not set
 CONFIG_ZONE_DMA_FLAG=0