From 4c1661b830ca91a72fe71c65cfcbcf121e836436 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 21 Mar 2014 15:54:07 +0000
Subject: [PATCH] build: remove check to nonexistant CONFIG_ENABLE_LOCALE
 variable and move DISABLE_NLS to package-defaults.mk

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39980 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/package-defaults.mk | 1 +
 rules.mk                    | 6 ------
 toolchain/gdb/Makefile      | 1 -
 toolchain/insight/Makefile  | 1 -
 4 files changed, 1 insertion(+), 8 deletions(-)

diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 62ccbb93ef..8f35c3293e 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -64,6 +64,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
 endif
 
 EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
+DISABLE_NLS:=--disable-nls
 
 CONFIGURE_PREFIX:=/usr
 CONFIGURE_ARGS = \
diff --git a/rules.mk b/rules.mk
index 0769a09278..cc02b91bc9 100644
--- a/rules.mk
+++ b/rules.mk
@@ -260,12 +260,6 @@ else
     $(SCRIPT_DIR)/rstrip.sh
 endif
 
-ifeq ($(CONFIG_ENABLE_LOCALE),true)
-  DISABLE_NLS:=--enable-nls
-else
-  DISABLE_NLS:=--disable-nls
-endif
-
 ifeq ($(CONFIG_IPV6),y)
   DISABLE_IPV6:=
 else
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 627baff528..10de1f883f 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -29,7 +29,6 @@ define Host/Configure
 		--host=$(GNU_HOST_NAME) \
 		--target=$(REAL_GNU_TARGET_NAME) \
 		--disable-werror \
-		$(DISABLE_NLS) \
 		--without-uiout \
 		--disable-tui --disable-gdbtk --without-x \
 		--without-included-gettext \
diff --git a/toolchain/insight/Makefile b/toolchain/insight/Makefile
index 9fb39e1932..3744f56451 100644
--- a/toolchain/insight/Makefile
+++ b/toolchain/insight/Makefile
@@ -28,7 +28,6 @@ define Host/Configure
 		--build=$(GNU_HOST_NAME) \
 		--host=$(GNU_HOST_NAME) \
 		--target=$(REAL_GNU_TARGET_NAME) \
-		$(DISABLE_NLS) \
 		--enable-threads \
 		--enable-werror=no \
 	);
-- 
GitLab