diff --git a/package/Makefile b/package/Makefile
index eab3f85dd6cb2486fca4ebd0a40753383a8935a2..e88efdfe9f692e6061b3843041af6c4a1bfb6fc8 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -89,15 +89,7 @@ $(curdir)/install: $(TMP_DIR)/.build
 	done || true
 	@-$(MAKE) package/preconfig
 	@if [ -d $(TOPDIR)/files ]; then \
-		( cd $(TOPDIR)/files; find -type f ) | \
-			( cd $(TARGET_DIR); while :; do \
-				read FILE; \
-				[ -z "$$FILE" ] && break; \
-				[ -L "$$FILE" ] || continue; \
-				echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
-				rm -f "$$FILE"; \
-			done; ); \
-		$(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
+		$(call file_copy,$(TOPDIR)/files/.,$(TARGET_DIR)); \
 	fi
 	@mkdir -p $(TARGET_DIR)/etc/rc.d
 	@( \