From 6a5cd848312e0ce10487a89b01456d8e1c4f66f4 Mon Sep 17 00:00:00 2001
From: juhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Wed, 20 Feb 2013 08:27:26 +0000
Subject: [PATCH] mpc85xx: use a foreach loop to copy boot images

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35689 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/mpc85xx/image/Makefile | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index b762515ec3..0826cfb27b 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -8,9 +8,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 DTS_TARGETS = mpc8548cds_32b p1010rdb
+BOOT_IMAGES:=zImage
 
 define Image/Prepare
-	cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+	$(foreach image,$(BOOT_IMAGES),
+		cp $(LINUX_DIR)/arch/powerpc/boot/$(image) $(KDIR)/$(image)
+	)
 endef
 
 define Image/BuildKernel
-- 
GitLab