From 6d0c73d11bf42070b9a4732b68411e0696f673f2 Mon Sep 17 00:00:00 2001
From: jow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 2 Dec 2012 12:20:34 +0000
Subject: [PATCH] rules.mk: provide a macro "file_copy" which removes any
 symlink in the destination dir that would be overwritten

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34437 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 rules.mk | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

diff --git a/rules.mk b/rules.mk
index 36bd22cac7..7139f79ef8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -287,6 +287,24 @@ define locked
 		-c '$(subst ','\'',$(1))'
 endef
 
+# Recursively copy paths into another directory, purge dangling
+# symlinks before.
+# $(1) => File glob expression
+# $(2) => Destination directory
+define file_copy
+	for src_dir in $(sort $(foreach d,$(wildcard $(1)),$(dir $(d)))); do \
+		( cd $$src_dir; find -type f -or -type d ) | \
+			( cd $(2); while :; do \
+				read FILE; \
+				[ -z "$$FILE" ] && break; \
+				[ -L "$$FILE" ] || continue; \
+				echo "Removing symlink $(2)/$$FILE"; \
+				rm -f "$$FILE"; \
+			done; ); \
+	done; \
+	$(CP) $(1) $(realpath $(2)/)/
+endef
+
 # file extension
 ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))
 
-- 
GitLab