From 97ba0b3c80a974f390bf4c1ffe34ebe25e5bc42c Mon Sep 17 00:00:00 2001
From: jow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 11 Mar 2013 20:52:20 +0000
Subject: [PATCH] firewall3: update to git head

 * Fixes compilation against eglibc
 * Fixes tracking logic when selectively restarting IPv4 or IPv6 firewall
 * Fixes tracking logic for user chains by differentiating between reloads and restarts
 * Introduces per-zone user chains {input,output,forwarding,prerouting,postrouting}_$zone_rule
 * Supports legacy "tcpudp" protocol notation again

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35969 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/network/config/firewall3/Makefile            | 4 ++--
 package/network/config/firewall3/files/firewall.user | 3 +++
 2 files changed, 5 insertions(+), 2 deletions(-)

diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index cd9405eae4..5b20dadefe 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall3
-PKG_VERSION:=2013-03-02
+PKG_VERSION:=2013-03-11
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=46536e5263c4bf57a91c38b5d08d78c774649dda
+PKG_SOURCE_VERSION:=87c4f12e16ae726e20774ee58468fa751a79a2c1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
diff --git a/package/network/config/firewall3/files/firewall.user b/package/network/config/firewall3/files/firewall.user
index 1ccbd01657..6f799063f5 100644
--- a/package/network/config/firewall3/files/firewall.user
+++ b/package/network/config/firewall3/files/firewall.user
@@ -2,3 +2,6 @@
 # Put your custom iptables rules here, they will
 # be executed with each firewall (re-)start.
 
+# Internal uci firewall chains are flushed and recreated on reload, so
+# put custom rules into the root chains e.g. INPUT or FORWARD or into the
+# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
-- 
GitLab