From a8e209c8cf39812e54364191c5636c5c9b7130cc Mon Sep 17 00:00:00 2001
From: blogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sat, 21 Mar 2015 21:48:12 +0000
Subject: [PATCH] kernel: Support kernel options required by systemd

These kernel options are all likely to be widely useful in this modern age, but
are immediately useful for systemd support.

c.f. http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild?&view=markup#l118

Adapted from a patch by Adam Porter.

Signed-off-by: Jeff Waugh <jdub@bethesignal.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44929 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 config/Config-kernel.in | 34 ++++++++++++++++++++++++++++------
 1 file changed, 28 insertions(+), 6 deletions(-)

diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 437a6230d7..a0d9472dcb 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -135,6 +135,18 @@ config KERNEL_DIRECT_IO
 	bool "Compile the kernel with direct IO support"
 	default n
 
+config KERNEL_FHANDLE
+	bool "Compile the kernel with support for fhandle syscalls"
+	default n
+
+config KERNEL_FANOTIFY
+	bool "Compile the kernel with modern file notification support"
+	default n
+
+config KERNEL_BLK_DEV_BSG
+	bool "Compile the kernel with SCSI generic v4 support for any block device"
+	default n
+
 config KERNEL_MAGIC_SYSRQ
 	bool "Compile the kernel with SysRq support"
 	default y
@@ -184,6 +196,22 @@ config USE_SPARSE
 	bool "Enable sparse check during kernel build"
 	default n
 
+config KERNEL_DEVTMPFS
+	bool "Compile the kernel with device tmpfs enabled"
+	default n
+	help
+	  devtmpfs is a simple, kernel-managed /dev filesystem. The kernel creates
+	  devices nodes for all registered devices ti simplify boot, but leaves more
+	  complex tasks to userspace (e.g. udev).
+
+if KERNEL_DEVTMPFS
+
+	config KERNEL_DEVTMPFS_MOUNT
+		bool "Automatically mount devtmpfs after root filesystem is mounted"
+		default n
+
+endif
+
 #
 # CGROUP support symbols
 #
@@ -501,9 +529,3 @@ config KERNEL_SECCOMP_FILTER
 		default n
 		help
 		  Build kernel with support for seccomp BPF programs.
-
-config KERNEL_FHANDLE
-	bool "Enable open by fhandle syscalls"
-		default n
-		help
-		  Build kernel with support for open by fhandle syscalls
-- 
GitLab