From c4f7ec1b700ef193bfa4bba6fd82afdd51f279e2 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Wed, 7 Jan 2015 16:02:59 +0000
Subject: [PATCH] package/binutils: actually support the target toolchain

This fixes a bug, where ld on ARM EABI platforms expects OABI code.

Signed-off-by: Harald Geyer <harald@ccbib.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43866 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/devel/binutils/Makefile | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index cf7769013c..c5a0717477 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -69,6 +69,8 @@ endef
 TARGET_CFLAGS += $(FPIC) -Wno-unused-value
 
 CONFIGURE_ARGS += \
+	--host=$(REAL_GNU_TARGET_NAME) \
+	--target=$(REAL_GNU_TARGET_NAME) \
 	--enable-shared \
 	--enable-install-libiberty \
 	--enable-install-libbfd
-- 
GitLab