diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index b7baf05da80202b79f29898f7b667d24b86fa2cc..a8f4adaa0c1a9fd3987e14e0149687894e9f9524 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2013-01-28
+PKG_VERSION:=2013-01-28.1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
diff --git a/package/network/config/netifd/files/etc/hotplug.d/iface/10-ipv6-static b/package/network/config/netifd/files/etc/hotplug.d/iface/10-ipv6-static
index 9f5b72716b4608f8f6c6f83a38ec73ea8bc611c0..7f671b1c218414484fcb91f1aaa445ab1ebc7088 100644
--- a/package/network/config/netifd/files/etc/hotplug.d/iface/10-ipv6-static
+++ b/package/network/config/netifd/files/etc/hotplug.d/iface/10-ipv6-static
@@ -10,6 +10,10 @@ case "$ACTION" in
 		if [ "$proto" = "static" -a "$ip6slaac" = "1" ]; then
 			echo 2 > "/proc/sys/net/ipv6/conf/$DEVICE/accept_ra"
 			echo 2 > "/proc/sys/net/ipv6/conf/$DEVICE/forwarding"
+
+			# Though this should be save here, it is not recommended
+			echo 1 > "/proc/sys/net/ipv6/conf/$DEVICE/disable_ipv6"
+			echo 0 > "/proc/sys/net/ipv6/conf/$DEVICE/disable_ipv6"
 		fi
 	;;
 esac