From d67080379e5df98d1ab3f3c51b624e3311f4725e Mon Sep 17 00:00:00 2001
From: blogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Tue, 17 Sep 2013 21:44:52 +0000
Subject: [PATCH] libubox: add packaging info for uloop lua binding

Signed-off-by: John Crispin <blogic@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38018 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/libs/libubox/Makefile | 13 +++++++++++++
 1 file changed, 13 insertions(+)

diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index 2d6967bdca..f79a34f963 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -54,6 +54,13 @@ define Package/libjson-script
   TITLE:=Minimalistic JSON based scripting engine
 endef
 
+define Package/libubox-lua
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libubox +liblua
+  TITLE:=Lua binding for the OpenWrt Basic utility library
+endef
+
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 CMAKE_OPTIONS = \
 	-DLUAPATH=/usr/lib/lua
@@ -79,7 +86,13 @@ define Package/libjson-script/install
 	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libjson_script.so $(1)/lib/
 endef
 
+define Package/libubox-lua/install
+	$(INSTALL_DIR) $(1)/usr/lib/lua
+	$(CP) $(PKG_BUILD_DIR)/lua/uloop.so $(1)/usr/lib/lua/
+endef
+
 $(eval $(call BuildPackage,libubox))
 $(eval $(call BuildPackage,libblobmsg-json))
 $(eval $(call BuildPackage,jshn))
 $(eval $(call BuildPackage,libjson-script))
+$(eval $(call BuildPackage,libubox-lua))
-- 
GitLab