diff --git a/package/Makefile b/package/Makefile
index e189e37043c117359083112e2fcfd979b9ecfbfb..1930d27cf8b31640ddf6aca8d6816312f81373d0 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,7 +26,7 @@ ifdef CONFIG_USE_MKLIBS
   define mklibs
 	rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
 	# first find all programs and add them to the mklibs list
-	find $(STAGING_DIR_ROOT) -type f -perm +100 -exec \
+	find $(STAGING_DIR_ROOT) -type f -perm /100 -exec \
 		file -r -N -F '' {} + | \
 		awk ' /executable.*dynamically/ { print $$1 }' > $(TMP_DIR)/mklibs-progs
 	# find all loadable objects that are not regular libraries and add them to the list as well