diff --git a/package/Makefile b/package/Makefile
index f5ff8563f38b46da4e2a71fd5601b74040f12c54..9a641881a353f98c709fcbda55911775a0297e84 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,9 +26,9 @@ ifeq ($(QUIET),1)
 %-compile %-install: FORCE
 	$(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
 
-%-prereq %-download %-clean: FORCE
+%-prepare %-prereq %-download %-clean: FORCE
 else
-%-prereq %-download %-clean %-compile %-install: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
 endif
 	$(MAKE) -C $* $(patsubst $*-%,%,$@)