diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 2cef2653bf1db6b0d3554e74219fc9b42346bb5a..c74efbe1df71f0dc5b97017924062258ff6f3261 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -8,13 +8,15 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+  define Build/Clean
 	$(MAKE) -C u-boot clean
-endef
+  endef
 
-define Build/Compile
+  define Build/Compile
 	$(MAKE) -C u-boot compile
-endef
+  endef
+endif
 
 define Image/Prepare
 	cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage