From f7fb74d4987ce9a07e483a243432ed01257a6cd7 Mon Sep 17 00:00:00 2001
From: mbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Wed, 2 Aug 2006 13:06:58 +0000
Subject: [PATCH] only rebuild the package index when the *.ipk files have
 changed

git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4395 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/package/Makefile b/package/Makefile
index 85f852fd54..c2015b3a41 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -55,6 +55,8 @@ install:
 	rm -rf $(BUILD_DIR)/root
 	$(MAKE) install-targets
 
-index: FORCE
+index: $(PACKAGE_DIR)/Packages
+
+$(PACKAGE_DIR)/Packages: $(PACKAGE_DIR)/*.ipk
 	(cd $(PACKAGE_DIR); $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages)
 
-- 
GitLab