From fc4c3342f366fdc792124749ec019ed492f2976a Mon Sep 17 00:00:00 2001
From: thepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 5 Mar 2010 20:28:52 +0000
Subject: [PATCH] this patch fixes package/Makefile.

-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20000 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/Makefile | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/package/Makefile b/package/Makefile
index 5734f9854c..5468bdc718 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -23,6 +23,7 @@ endif
 $(curdir)/install:=$(curdir)/install-cleanup
 
 $(curdir)/cleanup: $(TMP_DIR)/.build
+	- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
 	rm -rf $(TARGET_DIR) $(STAGING_DIR_ROOT)
 
 ifdef CONFIG_USE_MKLIBS
@@ -42,8 +43,9 @@ ifdef CONFIG_USE_MKLIBS
 		--sysroot $(STAGING_DIR_ROOT) \
 		-L /lib \
 		-L /usr/lib \
+		-L /usr/lib/ebtables \
 		--ldlib $(patsubst $(STAGING_DIR_ROOT)/%,/%,$(firstword $(wildcard \
-			$(foreach name,ld-uClibc.so.* ld-linux.so.*, \
+			$(foreach name,ld-uClibc.so.* ld-linux.so.* ld-*.so, \
 			  $(STAGING_DIR_ROOT)/lib/$(name) \
 			)))) \
 		--target $(REAL_GNU_TARGET_NAME) \
-- 
GitLab