From fdb86f6271ef18df7735975a172df9939b6c3269 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 30 Nov 2006 18:30:16 +0000
Subject: [PATCH] another round of ppc fixes - the unfinished include/asm-ppc
 => asm-powerpc migration causes trouble

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5683 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 toolchain/kernel-headers/Makefile                  |  4 +++-
 toolchain/uClibc/patches/180-powerpc_headers.patch | 13 +++++++++++++
 2 files changed, 16 insertions(+), 1 deletion(-)
 create mode 100644 toolchain/uClibc/patches/180-powerpc_headers.patch

diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index 4cd0199e78..d2d9c3dd32 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -26,7 +26,9 @@ define Build/Prepare
 endef
 
 define Build/Configure/powerpc
-	$(CP) $(PKG_BUILD_DIR)/include/asm-powerpc/* $(PKG_BUILD_DIR)/include/asm-ppc/
+	$(CP) $(PKG_BUILD_DIR)/include/asm-ppc/* $(PKG_BUILD_DIR)/include/asm-powerpc/
+	rm -rf $(PKG_BUILD_DIR)/include/asm-ppc
+	mv $(PKG_BUILD_DIR)/include/asm-powerpc $(PKG_BUILD_DIR)/include/asm-ppc
 endef
 
 define Build/Configure
diff --git a/toolchain/uClibc/patches/180-powerpc_headers.patch b/toolchain/uClibc/patches/180-powerpc_headers.patch
new file mode 100644
index 0000000000..98af0c03c6
--- /dev/null
+++ b/toolchain/uClibc/patches/180-powerpc_headers.patch
@@ -0,0 +1,13 @@
+diff -ur uClibc.old/libc/sysdeps/linux/powerpc/bits/kernel_types.h uClibc.dev/libc/sysdeps/linux/powerpc/bits/kernel_types.h
+--- uClibc.old/libc/sysdeps/linux/powerpc/bits/kernel_types.h	2005-08-18 00:49:41.000000000 +0200
++++ uClibc.dev/libc/sysdeps/linux/powerpc/bits/kernel_types.h	2006-11-30 19:26:22.000000000 +0100
+@@ -4,7 +4,8 @@
+  * our private content, and not the kernel header, will win.
+  *  -Erik
+  */
+-#if ! defined _PPC_POSIX_TYPES_H && ! defined _PPC64_POSIX_TYPES_H
++#if ! defined _PPC_POSIX_TYPES_H && ! defined _PPC64_POSIX_TYPES_H && !defined _ASM_POWERPC_POSIX_TYPES_H
++#define _ASM_POWERPC_POSIX_TYPES_H
+ #define _PPC_POSIX_TYPES_H
+ #define _PPC64_POSIX_TYPES_H
+ 
-- 
GitLab