requirements.txt 799 Bytes
Newer Older
1 2
# Pour installer toute ces dépendances avec pip, vous avez besoin d'avoir installé
# les paquets suivant:
3
# libsmi2-dev libsasl2-dev postgresql-server-dev-all libsnmp-dev libzmq3-dev libczmq-dev gettext
4

5 6
# On force django 1.10 qui est la version utilisée en prod
Django >= 1.10,< 1.11
7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
# idem, on force la verison de reversion a celle de prod
django-reversion == 1.8.4

netaddr >= 0.7.12
unidecode >= 0.04.16
passlib >= 1.6.1
snimpy >= 0.8.3 # require libsmi2-dev

django-cas-ng
BeautifulSoup
requests
ipaddr
python-ldap # require libsasl2-dev


# dépencances supplémentaire lc_ldap
netifaces
python-dateutil


# dépendances supplémentaire /usr/scripts
psycopg2 # require postgresql-server-dev-all
netsnmp-py # require libsnmp-dev libzmq3-dev libczmq-dev
paramiko
jinja2
markdown
MySQL-python