Update .travis.yml to use python3 for flake8, check_rst and coverage

14 jobs for dev in 9 minutes and 43 seconds (queued for 8 minutes and 52 seconds)
latest
Status Job ID Name Coverage
  Test
passed #3537
check_rst

00:00:28

passed #3549
coverage

00:01:05

99.0%
passed #3536
flake8

00:00:29

passed #3541
py27-django110

00:00:58

passed #3538
py27-django17

00:00:57

passed #3539
py27-django18

00:00:58

passed #3540
py27-django19

00:00:58

failed #3545
py34-django110

00:00:23

failed #3542
py34-django17

00:00:40

failed #3543
py34-django18

00:00:38

failed #3544
py34-django19

00:00:23

passed #3548
py35-django110

00:00:57

failed #3546
py35-django18

00:00:21

failed #3547
py35-django19

00:00:21

 
Name Stage Failure
failed
py35-django19 Test
Collecting pyparsing>=2.0.2
Downloading https://files.pythonhosted.org/packages/5d/bc/1e58593167fade7b544bfe9502a26dc860940a79ab306e651e7f13be68c2/pyparsing-2.4.6-py2.py3-none-any.whl (67kB)
Collecting more-itertools
Downloading https://files.pythonhosted.org/packages/68/03/0604cec1ea13c9f063dd50f900d1a36160334dd3cfb01fd0e638f61b46ba/more_itertools-8.0.2-py3-none-any.whl (40kB)
Installing collected packages: more-itertools, zipp, importlib-metadata, toml, six, pluggy, pyparsing, packaging, filelock, virtualenv, py, tox
Successfully installed filelock-3.0.12 importlib-metadata-1.3.0 more-itertools-8.0.2 packaging-19.2 pluggy-0.13.1 py-1.8.1 pyparsing-2.4.6 six-1.13.0 toml-0.10.0 tox-3.14.3 virtualenv-16.7.9 zipp-0.6.0
$ tox -e py35-django19
ERROR: unknown environment 'py35-django19'
ERROR: Job failed: exit code 1
failed
py35-django18 Test
Collecting zipp>=0.5
Downloading https://files.pythonhosted.org/packages/74/3d/1ee25a26411ba0401b43c6376d2316a71addcc72ef8690b101b4ea56d76a/zipp-0.6.0-py2.py3-none-any.whl
Collecting more-itertools
Downloading https://files.pythonhosted.org/packages/68/03/0604cec1ea13c9f063dd50f900d1a36160334dd3cfb01fd0e638f61b46ba/more_itertools-8.0.2-py3-none-any.whl (40kB)
Installing collected packages: six, pyparsing, packaging, more-itertools, zipp, importlib-metadata, pluggy, virtualenv, filelock, toml, py, tox
Successfully installed filelock-3.0.12 importlib-metadata-1.3.0 more-itertools-8.0.2 packaging-19.2 pluggy-0.13.1 py-1.8.1 pyparsing-2.4.6 six-1.13.0 toml-0.10.0 tox-3.14.3 virtualenv-16.7.9 zipp-0.6.0
$ tox -e py35-django18
ERROR: unknown environment 'py35-django18'
ERROR: Job failed: exit code 1
failed
py34-django110 Test
  Stored in directory: /root/.cache/pip/wheels/91/95/75/19c98a91239878abbc7c59970abd3b4e0438a7dd5b61778335
Successfully built scandir
Installing collected packages: toml, more-itertools, zipp, six, scandir, pathlib2, importlib-metadata, pyparsing, packaging, py, pluggy, filelock, virtualenv, tox
Successfully installed filelock-3.0.12 importlib-metadata-0.23 more-itertools-7.2.0 packaging-19.2 pathlib2-2.3.5 pluggy-0.13.1 py-1.8.1 pyparsing-2.4.6 scandir-1.10.0 six-1.13.0 toml-0.10.0 tox-3.14.0 virtualenv-16.7.9 zipp-0.6.0
You are using pip version 19.0.3, however version 19.1.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
$ tox -e py34-django110
ERROR: unknown environment 'py34-django110'
ERROR: Job failed: exit code 1
failed
py34-django19 Test
  Stored in directory: /root/.cache/pip/wheels/91/95/75/19c98a91239878abbc7c59970abd3b4e0438a7dd5b61778335
Successfully built scandir
Installing collected packages: more-itertools, zipp, scandir, six, pathlib2, importlib-metadata, py, pyparsing, packaging, virtualenv, toml, pluggy, filelock, tox
Successfully installed filelock-3.0.12 importlib-metadata-0.23 more-itertools-7.2.0 packaging-19.2 pathlib2-2.3.5 pluggy-0.13.1 py-1.8.1 pyparsing-2.4.6 scandir-1.10.0 six-1.13.0 toml-0.10.0 tox-3.14.0 virtualenv-16.7.9 zipp-0.6.0
You are using pip version 19.0.3, however version 19.1.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
$ tox -e py34-django19
ERROR: unknown environment 'py34-django19'
ERROR: Job failed: exit code 1
failed
py34-django18 Test
    ERROR: This lxml version requires Python 2.7, 3.5 or later.
----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-5bs7jcl9/lxml/

=================================== log end ====================================
ERROR: could not install deps [Django>=1.8,<1.9, -r/builds/samir/django-cas-server/requirements-dev.txt]; v = InvocationError("/builds/samir/django-cas-server/.tox/py34-django18/bin/python -m pip install 'Django>=1.8,<1.9' -r/builds/samir/django-cas-server/requirements-dev.txt", 1)
___________________________________ summary ____________________________________
ERROR: py34-django18: could not install deps [Django>=1.8,<1.9, -r/builds/samir/django-cas-server/requirements-dev.txt]; v = InvocationError("/builds/samir/django-cas-server/.tox/py34-django18/bin/python -m pip install 'Django>=1.8,<1.9' -r/builds/samir/django-cas-server/requirements-dev.txt", 1)
ERROR: Job failed: exit code 1
failed
py34-django17 Test
    ERROR: This lxml version requires Python 2.7, 3.5 or later.
----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-j80wzk6i/lxml/

=================================== log end ====================================
ERROR: could not install deps [Django>=1.7,<1.8, -r/builds/samir/django-cas-server/requirements-dev.txt]; v = InvocationError("/builds/samir/django-cas-server/.tox/py34-django17/bin/python -m pip install 'Django>=1.7,<1.8' -r/builds/samir/django-cas-server/requirements-dev.txt", 1)
___________________________________ summary ____________________________________
ERROR: py34-django17: could not install deps [Django>=1.7,<1.8, -r/builds/samir/django-cas-server/requirements-dev.txt]; v = InvocationError("/builds/samir/django-cas-server/.tox/py34-django17/bin/python -m pip install 'Django>=1.7,<1.8' -r/builds/samir/django-cas-server/requirements-dev.txt", 1)
ERROR: Job failed: exit code 1