Update .travis.yml and setup.py to drop Django <1.11 and python 3.4 support

Status Job ID Name Coverage
  Test
canceled #1089
check_rst

canceled #1101
coverage

canceled #1088
flake8

canceled #1093
py27-django110

canceled #1090
py27-django17

canceled #1091
py27-django18

canceled #1092
py27-django19

canceled #1097
py34-django110

canceled #1094
py34-django17

canceled #1095
py34-django18

canceled #1096
py34-django19

canceled #1100
py35-django110

canceled #1098
py35-django18

canceled #1099
py35-django19